Network issues in Newark
Incident Report for MumbleBoxes
Resolved
Network issues in Newark appear to have been resolved.
Posted 7 months ago. Aug 26, 2016 - 03:04 UTC
Identified
We have identified network issues in our Newark datacenter.

We are contacting our provider staff.
Posted 7 months ago. Aug 26, 2016 - 02:27 UTC