Mumble Server Maintenance
Incident Report for MumbleBoxes
Resolved
Our maintenance is completed.
Posted 5 months ago. Sep 16, 2016 - 16:21 UTC
Identified
We are doing a quick mumble server maintenance this morning. You may be disconnected from your server for a brief moment.
Posted 5 months ago. Sep 16, 2016 - 14:57 UTC