Network Issues in Atlanta
Incident Report for MumbleBoxes
Resolved
This incident has been resolved.
Posted 12 months ago. May 13, 2016 - 15:36 UTC
Identified
Our datacenter staff has mitigated a large scale DDoS attack focused against the datacenter.

Network performance should be returning back to normal.
Posted 12 months ago. May 13, 2016 - 00:56 UTC