Emergency Maintenance Tokyo
Incident Report for MumbleBoxes
Resolved
This incident has been resolved.
Posted 4 months ago. Dec 07, 2016 - 02:19 UTC
Update
Tokyo is back up and active on much better nodes.

You should see improved performance and improved network connectivity.

We apologize for the abruptness of the maintenance, but the nodes were crashing randomly and causing massive issues.
Posted 4 months ago. Dec 07, 2016 - 02:18 UTC
Investigating
We are taking our Tokyo nodes down for emergency maintenance to migrate them to new hosts.
Posted 4 months ago. Dec 07, 2016 - 00:45 UTC