Network issues in Dallas
Incident Report for MumbleBoxes
Resolved
Network issues in Dallas have been resolved.
Posted 6 months ago. Sep 14, 2016 - 00:33 UTC
Identified
Our datacenter is investigating network issues to our Dallas datacenter.
Posted 6 months ago. Sep 13, 2016 - 21:09 UTC