Server Disconnects
Incident Report for MumbleBoxes
Resolved
This has been resolved.
Posted 7 months ago. Aug 25, 2016 - 01:01 UTC
Monitoring
We have identified an issue with some server updates that have caused some users to be disconnected.

You should be able to reconnect immediately.

We apologize for any inconvenience caused.
Posted 7 months ago. Aug 25, 2016 - 00:53 UTC